Windows Phone Thoughts - Daily News, Views, Rants and Raves

Check out the hottest Windows Mobile devices at our Expansys store!


Digital Home Thoughts

Loading feed...

Laptop Thoughts

Loading feed...

Android Thoughts

Loading feed...




Go Back   Thoughts Media Forums > WINDOWS PHONE THOUGHTS > Windows Phone Software

Reply
 
Thread Tools Display Modes
  #1  
Old 07-30-2006, 05:15 AM
Darius Wey
Developer & Designer, News Editor Emeritus
Darius Wey's Avatar
Join Date: Aug 2006
Posts: 12,959
Default Windows Mobile 5.0 ROM Update for the HP iPAQ hx4700

http://h18007.www1.hp.com/support/f...load/23729.html



HP has just released a ROM update for iPAQ hx4700 devices running Windows Mobile 5.0. According to the release history, it fixes a card response issue, and also improves overall system performance. Could this be what the doctor ordered? And if so, Dell, where in the world is the update for the X50/X50v?
__________________
Want the latest news, views, rants and raves? Visit our portal. Wish to contact me? Send me a private message or e-mail.
 
Reply With Quote
  #2  
Old 07-30-2006, 07:34 AM
Menneisyys
5000+ Posts? I Should OWN This Site!
Join Date: Jun 2007
Posts: 5,067

It seems itís indeed worth upgrading. The upgrade went smooth on all devices so far (unlike with, say, the A12 ROM upgrade on the Dell Axim x51v for many) and the entire device has become much speedier than before - even without hacks.

Iím testing the upgrade with my standard DockWare test to find out how filesys.exe behaves and to have some real, objective test results to present.

The problems / unresolved stuff Iíve come across so far:
  1. It still has incompatibility issues with a lot of games (Iíve tested Realms and DragonBall - the recently tested titles that didn't work. DragonBall, unlike with the previous WM5 version, has even crashed the entire device after crashing. In this respect, the upgrade may be even more incompatible than the previous one). This is strictly an hx4700 issue Ė these games run on my other WM5 (and/or VGA) devices just fine.
  2. Services.exe still consumes CPU: 1.2% by default, 0.8% with empty \Windows\Start Menu\Programs\Games, between 6.3 and 7.8% after copying every single factory-defult .lnk file from \Windows\Start Menu\Programs\ to \Windows\Start Menu\Programs\Games.

    Note that these figures are much better than with the original WM5 upgrade where, by default, the CPU usage of Services.exe was around 5% by default, 1% with a completely clean \Windows\Start Menu\Programs\Games and 15-20% with all the default links copied to the Games subdirectory.

    This means the Navi service must be disabled by hand in the new version too in the way I've explained in my previous tutorials.

I'll keep you posted on further results / remarks. You don't need to wait for them to upgrade, however - it seems it's really worth upgrading. Also, again, make sure you check out the MobilitySite forum comments here.
 
Reply With Quote
  #3  
Old 07-30-2006, 08:11 AM
KTamas
Thinker
Join Date: Dec 2006
Posts: 450

HP is actually posted an upgrade of a upgrade.

Hell. Frozen. Over.

(See that, Dell? Yes, You, with the x50v upgrade...)

:wink:
 
Reply With Quote
  #4  
Old 07-30-2006, 08:15 AM
juni
Sage
Join Date: Aug 2006
Posts: 761

Just installed it and it indeed went smooth . Menneisyys: You could post a link to your tutorial so I won't have to do a search (yes, I am lazy).
 
Reply With Quote
  #5  
Old 07-30-2006, 10:48 AM
dringo
Pupil
Join Date: Aug 2003
Posts: 15

Before upgrading you might want to read Biting the Handango that Feeds It: Are You Getting Your Money's Worth?
If like me you buy 90% of your Software from Handango and need to redownload lost files, this could prove to be one expensive upgrade what with their download "protection" farse.
The upgrade did go well and its very,very quick.
 
Reply With Quote
  #6  
Old 07-30-2006, 11:39 AM
juni
Sage
Join Date: Aug 2006
Posts: 761

I threw WA2, PB etc. etc. at it and it really is a lot faster . WA2 loads in one second compared to 30 seconds before the upgrade.
 
Reply With Quote
  #7  
Old 07-30-2006, 11:57 AM
Menneisyys
5000+ Posts? I Should OWN This Site!
Join Date: Jun 2007
Posts: 5,067
Default A quick question to hx4700 WM5 users

If you still haven't upgraded your hx4700 to the brand new, 2.0.1 WM5 version but you're still using the old, 2.0 one, could you please mail me / upload the \Program Files\Dockware\DockWare.exe present on the original, 2.0 WM5 HP iPAQ hx4700 version?

(If you mail it, rename it to, say, TXT or JPG before attaching it to your mail so that it gets through more reliably. My address is info removethis AT removethis winmobiletech.com.)

The new, 2.0.1 WM5 upgrade contains the latest, 2.0.2.1026 version, which can no longer be used for filesys.exe benchmarking (I've only noticed this after running the benchmark for 5 hours and without filesys.exe ever kicking in; unfortunately, Iíve forgotten to back up the old version, don't have the time to downgrade back to the old version and the old version isn't available anywhere any more) because it no longer creates temp files in the built-in storage memory.

Again, I only need the single \Program Files\Dockware\DockWare.exe file from the old WM5 version.

UPDATE (19:49 CET): thanks to Pocket PC Thoughts forum member "buckyg", I've received the old DockWare version in the meantime. That is, I do NOT need the file any more.

I've just started my all-night-long first test phase with near-empty storage & heavy deletions & writes so that the results are comparable to those of the previous version I've published earlier. Tomorrow, I'll go on with tests that simulate a hx4700 with full storage to see whether you may use the built-in storage to store files. Stay tuned!
 
Reply With Quote
  #8  
Old 07-30-2006, 12:02 PM
ethancaine
Intellectual
Join Date: Feb 2007
Posts: 116
Default Re: Windows Mobile 5.0 ROM Update for the HP iPAQ hx4700

Quote:
Originally Posted by Darius Wey
Could this be what the doctor ordered? And if so, Dell, where in the world is the update for the X50/X50v?
I'll tell you where... it's on eBay!

Oh, wait, no, that's where my x50v is after I got frustrated enough to sell the damned thing...
 
Reply With Quote
  #9  
Old 07-30-2006, 12:04 PM
Menneisyys
5000+ Posts? I Should OWN This Site!
Join Date: Jun 2007
Posts: 5,067

Quote:
Originally Posted by juni
Just installed it and it indeed went smooth . Menneisyys: You could post a link to your tutorial so I won't have to do a search (yes, I am lazy).
Delete HKEY_LOCAL_MACHINE\ Services\ NavPointService entirely. (See http://www.pocketpcmag.com/blogs/ind...;tb=1&pb=1 ).
 
Reply With Quote
  #10  
Old 07-30-2006, 12:13 PM
juni
Sage
Join Date: Aug 2006
Posts: 761

Thanks
 
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 08:07 PM.