Zune Thoughts

Zune Thoughts.com

Thanks for visiting Zune Thoughts - be sure to register in our forums!


Laptop Thoughts

Loading feed...

Windows Phone Thoughts

Loading feed...

Digital Home Thoughts

Loading feed...




Go Back   Thoughts Media Forums > ZUNE THOUGHTS > Zune Software

Reply
 
Thread Tools Display Modes
  #1  
Old 11-12-2007, 06:00 PM
Jason Dunn
Executive Editor
Jason Dunn's Avatar
Join Date: Aug 2006
Posts: 29,160
Default Zune v2: Strange Album Art Problem...Zune Finally Supports Embedded Album Art?

<div class='os_post_top_link'><a href='http://www.youtube.com/watch?v=5zlHaw9CojY' target='_blank'>http://www.youtube.com/watch?v=5zlHaw9CojY</a><br /><br /></div>As much as I like the new user interface and functionality of the new Zune desktop software, it has some curious glitches and bugs. I'll delve into them in my upcoming written article, but I decided to explore one of the &quot;visual&quot; bugs: the Zune software doesn't seem to see my album art. In this video you can see me find a Green Day track that has no album art associated with it. The problem? It does have album art - it's embedded in the file, and Vista can see it from the shell. I didn't film this, but Windows Media Player also shows the file as having album art. I think the root cause of this problem is that the Zune software completely ignores embedded album art...but only some of the time. <br /><br /><embed width="425" height="355" wmode="transparent" type="application/x-shockwave-flash" src="http://www.youtube.com/v/5zlHaw9CojY&amp;rel=1"></embed><br /><br /><div style="page-break-after: always;"><span style="display: none;">&nbsp;</span></div><br />I say &quot;some of the time&quot; because after I shot this video I did an experiment where I took an album I knew the Zune marketplace wouldn't have album art for, and I removed it from the library. I turned on hidden files and protected files, and deleted all the hidden album art files that had been generated. All I had was the MP3s with the embedded album art inside the file. I added the album back into my monitored music folder, and the Zune software picked it up within a few seconds. I checked the folder again after the scan, expecting to see a few hidden album art files generated by the Zune software. Nothing was there. <br /><br />Puzzled, I synced the album, sans folder album art, over to my Zune...and much to my amazement, the Zune displayed the album art! If I'm understanding what I'm seeing correctly, this means that the new Zunes finally support JPEG images embedded inside the audio files. This is something I've been hoping for since the first Zune information leaked more than a year ago, and it seems it's finally a reality! The question is, why doesn't the Zune desktop software pick up the embedded album art in the Green Day track? It picks up the album art from the album folder where I deleted the hidden albumart.jpg images. Does it scan the folder and read the embedded album art inside a folder, but not from a single file? So many questions - but it looks like at least part of my wish has been granted. Lots more to figure out...I look forward to your feedback on this issue once you get the new Zune software installed. Let's figure this one out together.
__________________
Want to contact me personally? Use this. Want to read my personal blog? Check it out. Want to follow me on Twitter? Here you go.
 
Reply With Quote
  #2  
Old 11-12-2007, 10:02 PM
Chris Gohlke
Contributing Editor Emeritus
Chris Gohlke's Avatar
Join Date: Aug 2006
Posts: 2,291

I was hoping this was something that would be fixed on V2. I've had problems with the Zune displaying the incorrect album art. Media Monkey and even the desktop zune software will both show the correct art, but then when loaded to the Zune, for a few songs, the incorrect art will show. I have to manually write down these songs when I see them, go into the zune desktop software and have it regrab the album information. Then it displays the correct art.
 
Reply With Quote
  #3  
Old 11-12-2007, 10:45 PM
Jason Dunn
Executive Editor
Jason Dunn's Avatar
Join Date: Aug 2006
Posts: 29,160

Quote:
Originally Posted by Chris Gohlke View Post
I was hoping this was something that would be fixed on V2. I've had problems with the Zune displaying the incorrect album art.
Huh, interesting! I haven't seen this problem with the original Zune software, but hearing that doesn't surprise me.
 
Reply With Quote
  #4  
Old 11-13-2007, 12:09 AM
Iain Gilbert
Neophyte
Join Date: Nov 2007
Posts: 1

I have a similar love of using high quality album art for my music files. I listened to your comments on this topic during Ian Dixon's podcast a little while back. I am tidying up my music folders now in preparation for the new Zune software being made available.

I will let you know my experience with embedded album art as I work things out.
 
Reply With Quote
  #5  
Old 11-13-2007, 06:22 PM
ChrisW
Ponderer
ChrisW's Avatar
Join Date: Nov 2007
Posts: 81

Strange, I've never had a problem like this with album art. I have oodles of tracks that have *only* embedded images, and they've always ended up showing correctly, both in the Zune PC software as well as the device.

The only problem I see with album art is if I don't have any embedded image, it will take some random image from the folder the track is in, which causes problems if I'm not organized properly.

On the other hand, I've had other problems with the Zune software reading the wrong data from tags. I've had a few instances where the Genre tags were out of sync -- one Genre listed in ID3v1 and a different one in ID3v2, and in some cases it's taken the (unwanted) ID3v1 tag rather than the v2 one.

Perhaps your experience is related to the version of ID3 that your art was written with?
 
Reply With Quote
  #6  
Old 11-13-2007, 09:39 PM
Jason Dunn
Executive Editor
Jason Dunn's Avatar
Join Date: Aug 2006
Posts: 29,160

Quote:
Originally Posted by ChrisW View Post
On the other hand, I've had other problems with the Zune software reading the wrong data from tags.
Yes, I've had some puzzling problems with the Zune software picking up the metadata wrong and saying that some songs are part of an album, when they're not. It's all a bit ugly actually - I don't know why Microsoft can't get something so simple right.

Quote:
Originally Posted by ChrisW View Post
Perhaps your experience is related to the version of ID3 that your art was written with?
Maybe. I use MediaMonkey to embed all album art.
 
Reply With Quote
  #7  
Old 11-14-2007, 12:12 AM
enjoythemusic
Pupil
enjoythemusic's Avatar
Join Date: Feb 2007
Posts: 40

See http://forums.thoughtsmedia.com/show...632#post126632
 
Reply With Quote
  #8  
Old 11-14-2007, 04:13 AM
Siouxperman
Neophyte
Join Date: Nov 2007
Posts: 3
Default Album Art Fix the worked for me

I figured out a very simply way to resolve nearly 100% of the problem with album art. I did a search for zunealbumart.jpg in My Music folder where all of my music folders are stored . I chose Select All after I found all of the files named zunealbumart.jpg and I deleted them. When I opened my Zune software all of my album art matched up.

The only remaining issue I have found has been extra albums in an artist that are actually another artist's albums. I resolved this by choosing the album that is under the wrong artist and deleting it. It deletes the "extra" copy and doesn't impact the album in the correct artist. Example: In the Zune Software when I click on artist Pearl Jam and look at Albums there are Pearl Jam albums and a couple stray U2 Albums. Just delete the stray U2 Albums from the Pearl Jam album choices. The stray U2 Albums still appear in the U2 section but don't show up in Pearl Jam any longer.

Hopefully this is helpful. It worked for me. We shouldn't have to do this but this takes care of most of the problems from what I can tell.
 
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 02:02 PM.