Log in

View Full Version : SD card stopped working... only in my phone... Only this SD card...

08-04-2006, 04:29 PM
OK had my O2 Exec (Universal) since last October...

Been using a 2GB SD card since day one that I also use in my camera...

Took card out and took pictures with camera the other day and when I put the SD card back in the Exec.... It didn't register the card sad.gif

The Exec can see my other SD cards and the 2GB sd card still works with card reader and my camera...
I have tried re-formating the SD card using both the camera and also on windows as FAT... No joy sad.gif

My mate has tried 2GB SD card in his PDA and it is working fine. I have tried his 512MB SD card and that is working fine...

Any ideas?

Darius Wey
08-04-2006, 05:36 PM
Have you installed any applications on your Exec recently?

Also, have you tried a soft-reset, and the more extreme solution of a hard-reset?

08-04-2006, 10:56 PM
Have already tried hard reset to no avail :(

If the sd card didn't work elsewhere then fine its the sd card.
If the Exec didn't work with other sd cards then fine its the Exec.
But why suddenly stop with only the 2gb card?

Its kinda wierd don't you think?

Darius Wey
08-05-2006, 03:35 AM
Its kinda wierd don't you think?

Yes, that is odd.

It could be a hardware failure. Your device is still under warranty, isn't it? It's probably best to contact O2, inform them of what you cannot do (no need to go into the details; just tell them that the device can't read your 2GB SD card, and mention that it has worked with the device before, and the card itself works on other devices), and then hopefully they'll repair or replace the device for free.