Log in

View Full Version : Setting up access to WAP sites using Rogers Canada

08-01-2003, 01:07 PM
Does anyone or has anyone set their Red-e Smartphone up through Rogers to access WAP sites. I have tried everything bu cannot get the ie browser included within SP2002 to work on WAP sites.

Any help would be greatly appreciated.

09-08-2003, 03:24 AM
I hate to see posts with 0 replies.
There is a program called WebWapSelect that may solve your problem. I am having troubles with WAP pages as well via TMobile in the US. I am going to try this solution and see if it works.
Good Luck.

Oh...the software can be found at the bottom of this page along with a great list of Smartphone Freeware.

09-21-2003, 01:18 AM
Thanks for the reply. I tried WebWapSelect a couple of months ago and it didnt help. The funny thing is that it screwed up my access to MSN Mobile and it took me weeks to find out what the problem was - even KrisKumar ws trying to give me a hand.

No such luck yet.

I will keep holding out for hope.

Thanks for the effort though it was much appreciated.


03-10-2004, 03:43 PM
Further to an earlier post, has anyone successfully used a Smartphone to browse Rogers' WAP homepage and WAP subpages?

I have an i-Mate/Tanager Smartphone and when I try to go to http://mymobilehomepage.rogers.com, despite having specified the WAP connection in PIE, I am taken to an html page rather than a WAP page.

I am sure I have the correct settings for WAP on my Smartphone (the apn, the username, password and primary and secondary dns settings). These were provided to me by Rogers.

I have searched for a standalone WAP browser for Smartphones, and have found none.


Mike Temporale
03-10-2004, 04:39 PM

That address doesn't even work from my desktop machine. Are you sure it's right?

03-10-2004, 04:58 PM
Mike, it does work from my desktop machine. I just tried it. Perhaps you could try again - the Rogers site was a little slow earlier this morning.


03-10-2004, 05:02 PM
I should also point out that the settings I received from Rogers work fine on my T39 Ericsson phone. That phone, of course, contains a standalone WAP-only browser.

Also, here are the settings I used, which are posted on the Rogers website:

Primary IP:
Primary Port: 9203
Secondary IP:
Secondary Port: 9201
APN: goam.com
Username: wapuser1
Password: wap
HomePage: http://mymobilehomepage.rogers.com/

You can assume that I subscribe to the Rogers data access/Navigate plans.


Mike Temporale
03-10-2004, 05:04 PM
ah, I see. There is a comma "," at the end of the URL above which caused it to fail when I clicked it. Cool. That's better. Let me try again from my phone. (I'm not a rogers user, but it should still let me get to that site.)

Mike Temporale
03-10-2004, 05:44 PM
Alright, it now works from my phone too.

I would guess that Rogers isn't correctly sniffing the PIE browser and therefore it loads the heavy graphics and tables. If you see that page, then your settings are correct. It would be Rogers that are not handling your browser correctly. Just my $0.02

03-10-2004, 08:33 PM
Mike, like you, I am seeing the html page. I agree with you that Rogers doesn't appear to be correctly sniffing PIE as a wap client. Oh well. I guess I'll have to use my T39 for browsing Rogers wap until a true wap client is written for the Smartphone platform.

03-13-2004, 12:05 AM
You should be able to get Rogers WAP if you change a couple of things.

I can get to the front WML (WAP) page but it won't let me in :( Looks like it's for rogers subscribers only.

Try this and see if works for you.

1 In Data connections make sure you have the following GPRS and proxy connection.

Create GPRS connection.
Description: Rogers WAP
Connects to: The Internet
Access point: goam.com
User name: wapuser1
Password: wap
Primary DNS:
Secondary DNS:
IP address: (blank)

Create proxy connection
Description: Rogers WAP proxy
Connects from: The Internet
Connects to: WAP network
Proxy (nameort): (or 208.200.67:151:9201)
Type: WAP
Username: blank
Password: blank

In data connections make 'WAP network: Rogers WAP'
In Internet Explorer uncheck 'auto detect settings' and make 'Select network: WAP network'. Forcing the WAP connection just makes it easier to test.

Try accessing site wsp://www.google.com/wml.
If you are successfully accessing the above WAP site via the WAP proxy server then Menu-Properties should show Protocol=Wireless Session Protocol.

2. Install a program called WebWapSelect which you can get at www.monolithix.org
Run the program and select the WAP option.

Now try and access wsp://mymobilehomepage.rogers.com

03-20-2004, 03:52 PM
Sorry it's taken me so long to reply. I tried all the settings in your first paragraph - creating the new data and proxy connections, etc. When I try to go to the google wap site you mention, my i-Mate reports that it's "connecting..." but never gets past that. When I try to go to the Rogers wap homepage, I get the same result. When I go back to my regular GPRS internet settings, I am able to surf, so the problem can't be that I'm in a bad signal zone. I'll double check that I followed your instructions exactly and report back. In the meantime, if you have any other ideas, I will receive them gratefully. Thank you very much for trying to help.